Groupwise 2012 crashed

LogoBlogNun so ganz stimmt die Überschrift nicht, denn es war lediglich eine Komponente des Groupwise-Systems die plötzlich den Geist aufgab. Der Groupwise Internet Agent (Gwia) wechselte gestern Nachmittag scheinbar grundlos seinen Status von running zu dead. Das eine der Komponenten gleich in den Hades marschierte, habe ich in den vergangenen 10 Jahren in denen ich Groupwise-Systeme administriere noch nicht erlebt. Da ja E-Mail einen ganz beträchtlichen Teil des heutigen Kommunikationsspektrums abdeckt, eine nicht unbeträchtliche Einschränkung der Arbeit hier in der Firma …

Dementsprechend waren die Reaktionen, sowohl meine als auch die meiner Kollegen …

Ein einfacher Neustart des Servers bzw. der Groupwise-Komponenten brachten keine Änderung. Ich widmete eine beträchtliche Zeit dem Studium der verfügbaren Log-Dateien, ohne allerdings konkrete Hinweise zu erhalten. Die folgende Recherche im Internet brachte einige Lösungsansätze und so gelang es mir tatsächlich den Gwia wieder Leben einzuhauchen. Allerdings „sprach“ mein Agent nicht mit seinem Partner dem Message Transfer Agenten (MTA). Jede Änderung am MTA führte stattdessen dazu, dass der Internet Agent wieder „starb“.

Eine umfangreiche Aktion (Umbenennung der Queue-Verzeichnisse beim GWIA und MTA) führten nicht zum erwarteten Ergebnis. Nunmehr lief der GWIA zwar stabil, aber die Kommunikation mit dem MTA funktionierte immer noch nicht. Nun blieb tatsächlich nur noch die Prüfung der einzelnen Verzeichnisse. Immerhin konnte ich feststellen, dass GWIA brav alle Mails einsammelte die an uns gerichtet waren, aber eben nicht weiterleitete …

Die weitere Suche brachte die Ursache für den „Tod“ meines Systems zu Tage: das Arbeitsverzeichnis des GWIA war durch ca. 100 Kopien ein und derselben Mail „verstopft“. Das Bereinigen dieses Verzeichnis brachten durchschlagenden Erfolg: innerhalb von 1 Minute wurden meinen Kollegen und mir insgesamt 245 Mails zugestellt – eben all das, was in den vergangenen Stunden unserem Server zugestellt worden war …

Im Moment versuche ich herauszufinden, ob hinter der ganzen Sache eine DoS-Attacke steckt oder alles nur ein „Unfall“ war. Ich neige noch immer zur ersten These.

Auf jeden Fall war es – wie einige MS-Jünger prompt behaupteten – kein Fehler im Groupwise-System. Angesichts der Tatsache, dass der Mailserver seit nunmehr 3 Jahren in der derzeitigen Umgebung klaglos und unauffällig seinen Dienst verrichtet, kein Grund über einen Wechsel nachzudenken …

Ich bitte meine Leser das Fachkauderwelsch zu entschuldigen 😉 , aber nach einer angespannten Nacht musste ich meiner Erleichterung Ausdruck verleihen …

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.