Trouble mit WordPress die 125.

Die Verwendung eines virtuellen Servers bringt so seine Probleme mit sich, u.a. muss man sich um Updates des Betriebssystems selbst kümmern. Mir war das so nicht bekannt und deshalb blieb mir vor 2 Wochen tatsächlich nur die Neuinstallation meines Servers. Mit Hilfe des Plugins Exportieren (ihr findet es unter Werkzeuge Exportieren) gelang es zwar relativ problemlos Beiträge und Kommentare aus WordPress zu exportieren und anschließend (wieder über Werkzeuge) in die neue Instanz zu importieren, aber die zugewiesenen Bilder usw. ließen sich auf diese Weise nicht wieder einbinden.

 Ich konnte zwar per FTP die entsprechenden Dateien wieder auf den Server kopieren, die Mediathek jedoch blieb leer und auch die Bilder in den Beiträgen fehlten. Ärgerlicherweise habe ich bisher keinen Weg gefunden, die Bilder in den Artikeln wieder einzubinden. Die Mediathek von WordPress führt offenbar keine Synchronisation mit den entsprechenden Upload-Verzeichnissen durch und selbst wenn man das bewerkstelligt (ich nutzte hierzu das Plugin Add to Server), stimmen die Datenbankeinträge nicht mit den verknüpften Images überein und die Bilder werden nicht angezeigt.

Inzwischen habe ich meine letzten (etwa 30) Beiträge soweit aktualisiert und die Einträge angepasst, dass die eingebundenen Bilder wieder sichtbar sind, aber diese Prozedur ist sehr mühsam und zeitaufwändig. Ich glaube nicht das ich alle vorhandenen etwa 1.300 Beiträge hier auf meiner WordPress-Instanz entsprechend „aufpimpen“ werde …

Nunmehr ergibt sich auch für mich die Notwendigkeit eines separaten Backups von WordPress. Allerdings bin ich nicht wirklich sicher, ob ein integriertes Backup von WordPress diese meine Vorstellungen umsetzen kann …

Ich werde ein wenig experimentieren und schauen, was dabei herauskommt. Irgendwann wird es wohl wieder notwendig sein, meinen virtuellen Server einem Update zu unterziehen und den dieses Mal betriebenen Aufwand möchte ich vermeiden.

Für eventuelle Tipps um nun doch noch meine alten Artikel mit den zugewiesenen Bildern zu versehen, wäre ich dankbar (so es denn solche gibt) … 

Wieder mal Trouble mit WordPress

So ganz allmählich beginnen mich die Probleme mit WordPress zu nerven. Dieses mal fand ich es besonders schlimm: nach einem Update des Plugins Jetpack war mein Blog nicht mehr erreichbar. Gemeldet wurde der allseits beliebte HTTP-Error 500 oder gar nichts, beim Aufruf des Blogs wurde lediglich der „white screen of dead“. Zuerst kam ich nicht auf den Verursacher, aber als es mir partout nicht gelingen wollte WordPress aufzurufen, brachte die Recherche diesen interessanten Thread zu Tage.

Hier dann die Meldung des Programmierers:

Die in der Folge vorgeschlagenen Lösungen – insbesondere das Update auf PHP 7 – wollte und konnte ich auf die Schnelle nicht realisieren. Also der sichere Weg: Backup vom Vorabend zurückspielen und abwarten.

Heute nun tatsächlich die Meldung, dass Jetpack auf Version 4.8.1 aktualisiert wurde. Aus Erfahrung etwas klüger geworden werde ich aber noch ein wenig warten, bevor ich meine WordPress-Instanz erneut „abschieße“ …

iThemes Security – Server hat keinen Speicher mehr

Es ist ja nicht das erste Mal, dass iThemes Security Schwierigkeiten auf meinem Server verursacht. Seit vergangenen Donnerstag erhielt ich regelmäßige Mails von meinem Server, dass für den Abschluß einer Operation nicht genügend Speicherplatz vorhanden sei. Da die Internetverbindung im Tiroler Urlaubsdomizil recht schmal war und ich wegen des Urlaubs auch keine rechte Lust hatte mich mit dem Problem zu beschäftigen, ignorierte ich die Meldungen erst einmal. Gestern dann Stufe 2 der Warnungen: mein Provider teilte mir mit, dass auf meinem vServer nur noch 5% Speicherkapazität vorhanden sei. Eine kurze Überprüfung ergab nichts. Mein WordPress ist nicht viel größer als 900 MB und der Server stellt mir immerhin 100 GB zur Verfügung.

Heute dann Stufe 3 des Szenarios – es war weder möglich die Administrationsseite von WordPress aufzurufen noch per Plesk auf die Einstellungen meines vServers zuzugreifen. Lediglich per FTP war der Zugriff noch möglich. Ich machte mich auf die Suche und wurde nach intensiver Suche schließlich fündig: das SQL-Backup von iThemes Security versuchte im Minutentakt Backups anzulegen und die Dateien hatten eine Größe zwischen 500 und 700 MB, seit Donnerstag waren so 90 GB zusammen gekommen. Das Löschen dieser Dateien zog sich ein wenig, aber bereits nachdem einige Dateien gelöscht waren, konnte ich wieder auf meine Administrationswerkzeuge nutzen …

Ich bin mir sicher, dass ich keine Backups per iThems Security eingestellt habe. Zur Sicherung der Daten setze ich Parallells Plesk ein, für mich als Backupstrategie vollkommen ausreichend. Was (oder wer?) das beschriebene Szenario in Gang gesetzt hat ist mir unklar. Auf jeden Fall habe ich die Backupoption in iThemes Security nunmehr deaktiviert und hoffe nunmehr meine Ruhe zu haben …