ownCloud 5.0.10 und die Encryption App

bannerowncloudBereits seit der Version 5.08 gehört eine Verschlüsselungs-Applikation zu ownCloud. Da ich ausschließlich per VPN auf meine Wolke zugreife, hat mich dieses Programm bisher nur am Rande interessiert. Heute wurde ich allerdings gleich zweimal mit diesem Programm konrontiert: einmal erhielt ich eine Mail in der ich um Hilfe gebeten wurde, zum anderen fand ich auch im Synology-Forum eine entsprechende Anfrage. Beide Nutzer haben dasselbe Problem: nach Aktivierung der Applikation Encryption und der geforderten Neuanmeldung, kommt die Fehlermeldung:

 
Missing Requirements!
Please make sure that PHP 5.3.3 is installed and that OpenSSL together with the PHP Extension is enabled and configured properly. For now the Encryption App is disabled.
 
Eine Überprüfung der installierten Versionen ergibt aber, dass PHP mit Version 5.3.24 (also deutlich neuer als die geforderte Version 5.3.3) installiert und auch OpenSSL in einer aktuellen Version installiert und seinen Dienst versieht. Was aber ist nun die Ursache für den Fehler? Nach einigem Suchen und Testen kam ich auf die Lösung: Synology installiert zwar mit dem DSM die entsprechenden Softwareversionen, weicht aber ein wenig vom Standard ab, genauer: ownCloud erwartet eine Datei opennssl.cnf in einem Verzeichnis des entsprechenden Servers. Dieses Verzeichnis und diese Datei existieren auf der Diskstation nicht! Nachdem eine Standard-Datei von mir in das entsprechende Verzeichnis kopiert wurde, wurde auch die Encryption-Applikation gestartet und letztendlich auch meine Dateien serverseitig verschlüsselt …
 
Folgende Schritte bin ich gegangen:
  1. Aufbau einer SSH-Verbindung zur Diskstation
  2. Anmeldung als root an der DS
  3. Wechsel in das Wurzelverzeichnis mit cd /
  4. cd /usr/syno
  5. mkdir ssl
    In diesem nun von mir erzeugten Unterverzeichnis erwartet ownCloud die Datei openssl.cnf
  6. Erzeugen einer openssl.cnf auf dem Rechner und Kopie in /usr/syno/ssl auf der Diskstation.
Den Inhalt der openssl.cnf findet ihr unter anderem im Synology-Forum in diesem Thread. Nach dieser Prozedur funktioniert alles reibungslos.
 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.