Botnet-News

LogoBlogSo allmählich nervt es: pünktlich zum Wochenende wurde mein Blog mal wieder per Bots angegriffen. Natürlich hatten sie wieder keinen Erfolg, aber die Penetranz und Heftigkeit der Angriffe geht mir doch ziemlich auf die Nerven. Hauptproblem dabei ist, dass durch die Vielzahl der Angriffe mein Webserver irgendwann so mit Anfragen zugeschossen wird, dass er irgendwann nur Error 404 bzw. Error 503 Meldungen „rausschmeisst“.

 
Insgesamt wurden gestern 1.357 IP-Adressen gesperrt. Wenn man allerdings weiß, dass das dahintersteckende Botnet nach vorsichtigen Schätzungen etwa 90.000 Rechner umfasst, ist das nicht gerade ermutigend. Die erste Attacke am Vormittag hat mein Server noch ganz gut weg gesteckt, die zweite in den frühen Abendstunden drückte ihm dann die Luft ab. Eine vollständige Sperrung der Domäne durch mich liess den weiteren Angriff dann ins Leere laufen, mein Blog war allerdings für ca. 2 Stunden komplett offline. Ein sehr unbefriedigender Zustand.
 
Neben den bereits implementierten Abwehrmechanismen habe ich deshalb einige weitere Massnahmen ergriffen, u.a. ist nunmehr mein Adminbereich ausschließlich SSL-verschlüsselt erreichbar. Die entsprechende Einstellung ist über das Plugin „Better WP-Security“ vorzunehmen, aber Vorsicht: zuerst prüfen, ob euer Webserver SSL überhaupt zulässt! Ansonsten sperrt ihr euch selbst von eurem Blog aus. Bei meinem virtuellen Server (Strato) war die entsprechende Einstellung kein Problem …
 
Ich werde abwarten, ob mich die vorgenommenen Änderungen nun endlich von diesen lästigen Botnet-Attacken befreien …

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.